## Revision History

<table>
<thead>
<tr>
<th>Revision Number</th>
<th>Revision Notes</th>
</tr>
</thead>
</table>
| **2.7**         | • Updated 1.2 Export Format  
• Updated 2.2 Creating Your Textbook  
• Updated 2.9 Re-sizing Invisible Audio Buttons  
• Updated 2.10 Editing a Plug-in's Title Text, Descriptions, and Alternative Text |
| **2.6**         | • Updated 2.2 Creating Your Textbook  
• Updated 2.7.1 Adding Plug-ins as Icons  
• Updated 2.9 Editing a Plug-in's Title Text, Descriptions, and Alternative Text  
• Updated 2.11 Deleting Plug-ins |
| **2.5**         | • Updated 1.1 Import Format  
• Updated 1.2 Export Format  
• Added 1.3 Selecting Your Language  
• Updated 1.4.3 Properties Panel  
• Updated 2.7 Adding Plug-ins  
• Added 2.7.1 Adding Plug-ins as Icons  
• Added 2.7.2 Adding Plug-ins as Hyperlinks  
• Updated 2.8 Moving Plug-in Icons  
• Updated 2.9 Editing a Plug-in's Title Text, Descriptions, and Alternative Text  
• Updated 2.10 Replacing a Plug-in’s Media File  
• Updated 2.11 Deleting Plug-ins |
| **2.0**         | • Updated 1.1 Import Format  
• Added 1.3.2.1 Rulers and Guide Lines  
• Updated 1.3.3 Properties Panel  
• Updated 1.4 Keyboard Shortcuts  
• Added 2.3 Building Your Table of Contents (and renumbered following sections)  
• Added 2.7 through 2.11 (Plug-ins)  
• Updated 3.1 Previewing Your Book  
• Updated 3.3 Uploading Your Book to KDP |
| **1.1**         | • Updated 1.2 Export Format  
• Updated 3.3 Uploading Your Book to KDP |
## Contents

1 Introduction .......................................................................................................................................... 4  
1.1 Import Format............................................................................................................................... 4  
1.2 Export Format ............................................................................................................................... 4  
1.3 Selecting Your Language ............................................................................................................... 4  
1.4 Kindle Textbook Creator Workspace ............................................................................................ 5  
1.4.1 Pages Panel ........................................................................................................................... 5  
1.4.2 Document Window ............................................................................................................... 6  
1.4.3 Properties Panel .................................................................................................................... 8  
1.5 Keyboard Shortcuts ..................................................................................................................... 10  
1.6 Automatic Updates ..................................................................................................................... 10  
2 Creating and Editing Your Textbook .............................................................................................. 11  
2.1 Preparing Your PDF ..................................................................................................................... 11  
2.2 Creating Your Textbook .............................................................................................................. 11  
2.3 Building Your Table of Contents.................................................................................................. 13  
2.4 Adding Pages............................................................................................................................... 15  
2.5 Moving Pages .............................................................................................................................. 16  
2.6 Deleting Pages.............................................................................................................................. 16  
2.7 Adding Plug-ins ........................................................................................................................... 17  
2.7.1 Adding Plug-ins as Icons ...................................................................................................... 17  
2.7.2 Adding Plug-ins as Hotlinks ................................................................................................. 19  
2.8 Moving Plug-in Icons .................................................................................................................. 21  
2.9 Re-sizing Invisible Audio Buttons ............................................................................................... 22  
2.10 Editing a Plug-in's Title Text, Descriptions, and Alternative Text ............................................. 22  
2.11 Replacing a Plug-in’s Media File ............................................................................................... 24  
2.12 Deleting Plug-ins ......................................................................................................................... 24  
3 Publishing Your Textbook ................................................................................................................ 26  
3.1 Previewing Your Book ................................................................................................................. 26  
3.2 Exporting Your Book ................................................................................................................... 27  
3.3 Uploading Your Book to KDP ...................................................................................................... 27
1 Introduction

Kindle Textbook Creator is a free tool designed to help authors and educators create, preview, and publish Kindle textbooks and supplemental educational materials without having to know any HTML or CSS.

1.1 Import Format


You can add audio, video, and image pop-ups to your textbook as icons or as hotlinks (see Section 2.7 Adding Plug-ins). Kindle Textbook Creator accepts the following file types:

- Video: .mp4
- Audio: .mp3
- Images: .jpg, .jpeg or .png

1.2 Export Format

Kindle Textbook Creator exports the finished book to a Kindle Package Format (.kpf) file that you can upload to Kindle Direct Publishing (KDP) to make it available to customers.

For more information on exporting and uploading your book, see Section 3.3.

1.3 Selecting Your Language

To display your preferred language in Kindle Textbook Creator, select File > Set UI Language and then choose your language from the list (see Figure 1).
1.4 Kindle Textbook Creator Workspace

The following sections describe the features of the Kindle Textbook Creator workspace (see Figure 2).

![Kindle Textbook Creator workspace](image)

**Figure 2: Kindle Textbook Creator workspace**

### 1.4.1 Pages Panel

The **Pages Panel** displays thumbnails of every page in your textbook (see Figure 3). You can use the **Pages Panel** to add, delete, or move pages.
To hide or display the **Pages Panel**, click the **View** button (see Figure 3) or select **View > Show/Hide Pages Panel**.

### 1.4.2 Document Window

The **Document Window** (see Figure 4) provides a detailed view of the page selected in the **Pages Panel**.
To adjust the zoom of the Document Window, select the Zoom menu (see Figure 5) or select View > Zoom In or View > Zoom Out.
1.4.2.1 Rulers and Guide Lines

Rulers and guide lines make it easier for you to position elements consistently throughout your book.

To hide or display rulers in the Document Window, select View > Show/Hide Rulers.

You can create vertical or horizontal guide lines by moving the cursor over the ruler, holding down the left mouse button, and dragging the cursor onto the page. The guide lines appear as yellow lines in the document window (see Figure 6).

![Figure 6: Rulers and ruler guides](image)

1.4.3 Properties Panel

The Properties Panel displays the options for the selected element:

- When you select a page thumbnail in the Pages Panel, the Properties Panel displays options for including that page in the table of contents (see Figure 7).
• When you select a plug-in icon or hotlink in the Document Window, the Properties Panel displays options for that plug-in (see Figure 8).
1.5 Keyboard Shortcuts

You can use the following keyboard shortcuts in Kindle Textbook Creator.

<table>
<thead>
<tr>
<th>Action</th>
<th>Windows Shortcut</th>
<th>Mac Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create New Book</td>
<td>CTRL + N</td>
<td>CMD + N</td>
</tr>
<tr>
<td>Open Book</td>
<td>CTRL + O</td>
<td>CMD + O</td>
</tr>
<tr>
<td>Close Book</td>
<td>CTRL + W</td>
<td>CMD + W</td>
</tr>
<tr>
<td>Save Book</td>
<td>CTRL + S</td>
<td>CMD + S</td>
</tr>
<tr>
<td>Save Book As</td>
<td>CTRL + SHIFT + S</td>
<td>CMD + SHIFT + S</td>
</tr>
<tr>
<td>Package for Publishing</td>
<td>CTRL + SHIFT + P</td>
<td>CMD + SHIFT + P</td>
</tr>
<tr>
<td>Undo Change</td>
<td>CTRL + Z</td>
<td>CMD + Z</td>
</tr>
<tr>
<td>Redo Change</td>
<td>CTRL + SHIFT + Z</td>
<td>CMD + SHIFT + Z</td>
</tr>
<tr>
<td>Delete Plug-in</td>
<td>DELETE</td>
<td>DELETE</td>
</tr>
<tr>
<td>Zoom In</td>
<td>CTRL + =</td>
<td>CMD + =</td>
</tr>
<tr>
<td>Zoom Out</td>
<td>CTRL + -</td>
<td>CMD + -</td>
</tr>
<tr>
<td>Fit to Window</td>
<td>CTRL + 0</td>
<td>CMD + 0</td>
</tr>
<tr>
<td>Fit Page Width</td>
<td>CTRL + 2</td>
<td>CMD + 2</td>
</tr>
</tbody>
</table>

1.6 Automatic Updates

When Amazon releases a new version of Kindle Textbook Creator, the application automatically downloads it for you. When Kindle Textbook Creator prompts you to install an update, Amazon recommends that you install the newest version to get all of the latest features.
2 Creating and Editing Your Textbook

2.1 Preparing Your PDF

Before you import your PDF, make sure that it includes bookmarks for each entry on the table of contents. After you upload your finished book to KDP, Amazon converts these bookmarks into an electronic table of contents that customers can use to navigate through your book.

2.2 Creating Your Textbook

To create a new Kindle textbook:

1. On the opening screen of Kindle Textbook Creator (see Figure 9), click **Create New Textbook from File**. The **Import from a PDF File** dialog box appears (see Figure 10).

![Kindle Textbook Creator opening screen](image_url)
2. Navigate to the PDF on your local hard drive, select the file, and click Open. Your PDF is imported and displayed in Kindle Textbook Creator (see Figure 11).
   - If there are hyperlinks in your PDF, Kindle Textbook Creator displays a message asking if you want them preserved. Click Yes to preserve them now or click No, Not for This Book to remove all hyperlinks. To be asked again later, click Remind Me and select a time period. You can also preserve links by selecting Edit > Preserve Links. Preserved links will appear underlined in the document window (see Figure 12).
3. Select **File > Save Book** to save your imported book. The **Save** dialog box opens (see Figure 13). Navigate to the location on your computer where you want to save the file. Enter the **File name**. Click **Save**.

![Save dialog box](image)

**Figure 13: Save dialog box**

### 2.3 Building Your Table of Contents

To build the table of contents for your textbook:

1. To open your book, select **File > Open Book**. The **Open a Kindle Textbook** dialog box appears (see Figure 14). Navigate to the folder where your book is saved, select the `.kcb` file, and then click **Open**. The book is displayed and ready to edit.
2. For each page that you want listed in the table of contents, select the page in the **Pages Panel**, check the box next to **Include Page in Table of Contents**, and type the table of contents entry in the **Page Title** box (see Figure 15). In the **Pages Panel**, each page that will be included in the table of contents is marked with a blue triangle in the upper left corner (see Figure 16).
3. To save your work, click **File > Save Book**.

### 2.4 Adding Pages

To add pages to your Kindle textbook:

1. To open your book, select **File > Open Book**. The **Open a Kindle Textbook** dialog box appears. Navigate to the folder where your book is saved, select the `.kcb` file, and then click **Open**. The book is displayed and ready to edit.
2. In the **Pages Panel**, right-click a thumbnail and select **Insert Page(s)** from the pop-up menu (see Figure 17). The **Import from a PDF File** dialog box appears.
3. Navigate to the PDF on your local hard drive, select the file that contains the pages you want to add, and click Open. The contents of the PDF are added to your book.
4. To save your work, click File > Save Book.

2.5 Moving Pages
To move pages in your Kindle textbook:

1. To open your book, select File > Open Book. The Open a Kindle Textbook dialog box appears. Navigate to the folder where your book is saved, select the .kcb file, and then click Open. The book is displayed.
2. In the Pages Panel, drag and drop the pages in the order you prefer. To select multiple pages, use SHIFT + click or CTRL + click.
3. To save your work, click File > Save Book.

2.6 Deleting Pages
To delete pages from your Kindle textbook:

1. To open your book, select File > Open Book. The Open a Kindle Textbook dialog box appears. Navigate to the folder where your book is saved, select the .kcb file, and then click Open. The book is displayed and ready to edit.
2. In the Pages Panel, select the thumbnail of the page you want to delete. Right-click the thumbnail and select Delete Selected Page from the pop-up menu (see Figure 18). The page is deleted.

3. To save your work, click File > Save Book.
2.7 Adding Plug-ins

With Kindle Textbook Creator, you can add audio, video, and image plug-ins to your textbook as icons (see Figure 19) or hotlinks (see Figure 20).

![Video plug-in icon](image1)

**Figure 19: Video plug-in icon**

![Video plug-in hotlink](image2)

**Figure 20: Video plug-in hotlink**

2.7.1 Adding Plug-ins as Icons

You can add audio, video, and image plug-ins to your textbook as icons. Kindle Textbook Creator accepts the following file types:

- Video: .mp4
- Audio: .mp3
- Images: .jpg, .jpeg or .png

To add plug-in icons to your Kindle textbook:

1. To open your book, select File > Open Book. The **Open a Kindle Textbook** dialog box appears. Navigate to the folder where your book is saved, select the .kcb file, and then click **Open**. The book is displayed.
2. Select **Edit > Insert** or click the **Insert** button (see Figure 21) and then select the type of plug-in that you would like to add (image, audio, or video).
3. A dialog box appears asking you to select the file that you want to add (see Figure 22). Navigate to the folder where your file is saved and click **Open**. The cursor changes to show the plug-in icon attached to it. Click the location where you want to place the plug-in and the icon appears on the page (see Figure 23).
If you are adding an audio plug-in, you can click the audio icon and use the options in the **Properties Panel** to customize the audio player (see Figure 24):

- Select **Play/Pause** for an inline audio player that keeps the user on the page.
- Select **Full Player** for a pop-up audio player.
- By default, the appearance of the audio player is **Icon Button**. If your content has an image or text that indicates that clicking it will play audio, you can select **Invisible Button** and place the invisible tap area over that image or text (for instructions on how to resize invisible audio buttons, see Section 2.9).

![Figure 24: Properties Panel--Audio options](image)

4. To save your work, click **File > Save Book**.

### 2.7.2 Adding Plug-ins as Hotlinks

You can add audio, video, and image plug-ins to your textbook as hotlinks. Kindle Textbook Creator accepts the following file types:

- Video: .mp4
- Audio: .mp3
- Images: .jpg, .jpeg or .png

To add plug-in hotlink to your Kindle textbook:
1. To open your book, select File > Open Book. The Open a Kindle Textbook dialog box appears. Navigate to the folder where your book is saved, select the .kcb file, and then click Open. The book is displayed.

2. Click the Select button (see Figure 25) and select the text that you want to link to the plug-in.

   ![Select button](Select_button.png)

   **Figure 25: Select button**

3. Click the Insert button (see Figure 26), select Link from Selection, and then select the type of plug-in that you would like to link to (image, audio, or video).

   ![Insert button](Insert_button.png)

   **Figure 26: Insert button**

4. A dialog box appears asking you to select the file that you want to add (see Figure 27). Navigate to the folder where your file is saved and click Open. The text that you selected is now hotlinked to that file (see Figure 28).
5. To save your work, click **File > Save Book**.

### 2.8 Moving Plug-in Icons

To move plug-in icons in your Kindle textbook:

1. To open your book, select **File > Open Book**. The **Open a Kindle Textbook** dialog box appears. Navigate to the folder where your book is saved, select the `.kcb` file, and then click **Open**. The book is displayed.
2. Click the plug-in’s icon to select it. A blue border appears to let you know that it is selected (see Figure 29).

3. Once the plug-in is selected, drag and drop it to your desired location.
4. To save your work, click File > Save Book.

2.9 Re-sizing Invisible Audio Buttons

To re-size invisible audio buttons in your Kindle textbook:

1. To open your book, select File > Open Book. The Open a Kindle Textbook dialog box appears. Navigate to the folder where your book is saved, select the .kcb file, and then click Open. The book is displayed.
2. Click the invisible audio button’s icon to select it. A blue border and selection points appear to let you know that it is selected (see Figure 30).

![Before and After Resizing](image)

Figure 30: Resizing Invisible Audio Button Before and After

3. Once the plug-in is selected, click one of the selection points in the direction that you want to resize the plug-in. Drag and release to resize.
4. To save your work, click File > Save Book.

2.10 Editing a Plug-in’s Title Text, Descriptions, and Alternative Text

To change a plug-in’s title text, description, or alternative text:

1. To open your book, select File > Open Book. The Open a Kindle Textbook dialog box appears. Navigate to the folder where your book is saved, select the .kcb file, and then click Open. The book is displayed.
2. Click the plug-in’s icon or hotlink to select it. If you have selected an icon, a blue border appears. If you have selected a hotlink, an orange border appears.
3. Once the plug-in is selected, the Properties Panel displays the plug-in’s Title, Short Description, and Alternative Text (see Figure 31). Edit these fields as needed.
4. To save your work, click File > Save Book.
Figure 31: Editing options in the Properties Panel

**Note:** For all plug-ins other than the Play/Pause audio toggle, this text will be displayed in the plug-in pop-up when viewed on Kindle reading platforms. The **Title** will be displayed prominently as the heading for your pop-up. The **Short Description** will be placed below the title to accompany your content. The **Alternative Text** will be used for accessibility features on Kindle platforms. By default, this text is automatically populated with the text from the **Title** and **Short Description** fields. For an example of how the text above would be displayed in an audio pop-up to customers, see Figure 32.
2.11 Replacing a Plug-in’s Media File

To replace a plug-in’s media file:

1. To open your book, select File > Open Book. The Open a Kindle Textbook dialog box appears. Navigate to the folder where your book is saved, select the .kcb file, and then click Open. The book is displayed.
2. Click the plug-in’s icon or hotlink to select it. If you have selected an icon, a blue border appears. If you have selected a hotlink, an orange border appears.
3. Once the plug-in is selected, the Properties Panel on the right side of the screen displays the plug-in’s properties (see Figure 31). Click the Replace button.
4. A dialog box appears asking you to select the file that you want to add. Navigate to the folder where your file is saved and click Open. The plug-in icon appears on the page.
5. To save your work, click File > Save Book.

2.12 Deleting Plug-ins

To delete plug-ins from your Kindle textbook:

1. To open your book, select File > Open Book. The Open a Kindle Textbook dialog box appears. Navigate to the folder where your book is saved, select the .kcb file, and then click Open. The book is displayed.
2. Click the plug-in’s icon or hotlink to select it. (To select multiple plug-ins, SHIFT + click on each plug-in.) If you have selected an icon, a blue border appears. If you have selected a hotlink, an orange border appears.

3. To remove the plug-in(s), select Edit > Delete or right-click the icon and select Delete.

4. To save your work, click File > Save Book.
3 Publishing Your Textbook

3.1 Previewing Your Book

When you have finished making changes to your book, Amazon recommends that you preview it to see how it will look on Kindle devices.

To preview your book:

1. Select the **Preview** button at the top-right of the screen. The **Previewer** and **Inspector** windows are displayed (see Figure 33).

![Figure 33: Previewer and Inspector windows](image-url)
2. Page through your book and review it. In the Inspector window, you can:
   - Use the **Device** tab to change the orientation, zoom level, and/or device. You can also
     navigate through the pages of your book.
   - Use the **TOC** tab to view and/or navigate your textbook’s table of contents file.

3. When you have finished previewing your book, click the **Close** button in the upper-right corner of the **Previewer** window.

### 3.2 Exporting Your Book

After you have previewed your book (see Section 3.1) and confirmed that you are satisfied with the quality, the next step is to export it.

To export your book:

1. Click **File > Package for Publishing**. The **Package Book** dialog box appears (see Figure 34).

   ![Figure 34: Package Book dialog box](image)

2. Navigate to the location on your local hard drive where you want to save your book and then click **Save**. A confirmation message is displayed. Click **OK**. Your book is saved as a .kpf file that you can upload to KDP.

### 3.3 Uploading Your Book to KDP

After your book is previewed (see Section 3.1) and exported (see Section 3.2), you are ready to upload it to KDP and make it available to Kindle customers.

**NOTE:** Books created with Kindle Textbook Creator can only be uploaded to KDP; they cannot be uploaded to Amazon Vendor Central at this time.
If you want to update a Kindle book that was created with Kindle Textbook Creator on KDP, you can use **Upload Your Book File** to update that book on your KDP bookshelf. However, if you want to update a Kindle book that was not created with Kindle Textbook Creator, you must use **Add new title** to create and submit a new book on your KDP bookshelf instead.

To upload your book:

1. Visit the KDP website at [https://kdp.amazon.com/](https://kdp.amazon.com/) or select **Help > Visit the Kindle Direct Publishing Website**. The KDP website opens in a browser window (see Figure 35).

   ![Figure 35: KDP website](image)

2. To sign in to the KDP website:
   - If you have an Amazon account, click the **Sign in** button to go to the **Sign in** page. Enter your **email address** and **password**, and then click the **Sign in using our secure server** button.
   - If you do not have an Amazon account, click the **Sign up** button to go to the **Sign in** page. Enter your **email address**, select the **I am a new customer** button, and then click the **Sign in using our secure server** button. On the **Registration** page, enter your **name**, **email address**, and **password**, and then click the **Create account** button.

3. The **KDP Bookshelf** page is displayed in your browser. Click the **Create new title** button. The **Your book** page is displayed.
4. Enter the information about your book in the fields on this page. All fields are required unless they are marked (optional).

5. Under **Upload Your Book File**, click the **Browse** button (see Figure 36). The **Open** dialog box is displayed.

6. Select a digital rights management (DRM) option: *(What's this?)*
   - Enable digital rights management
   - Do not enable digital rights management

   - Book content file:

   ![Figure 36: Browse button](image)

6. Navigate to the location where you saved your **.kpf** file, select the file, and then click **Open**. You will get a message that the book is processing.

7. When your book is successfully uploaded to KDP, the **Preview book** button is displayed (see Figure 37). Click the **Preview book** button and page through the book to confirm that you are satisfied with the conversion.

7. **Preview Your Book**

   *Previewing your book is an integral part of the publishing process and the best way to guarantee that your readers will have a good experience and see the book you want them to see.*

   **Online Previewer**

   *For most users, the online previewer is the best and easiest way to preview your content. The online previewer allows you to preview most books as they will appear on Kindle, Kindle Fire, iPad, and iPhone. If your book is fixed layout (for more information on fixed layout, see the Kindle Publishing Guidelines), the online previewer will display your book as it will appear on Kindle Fire.*

   ![Figure 37: Preview book button](image)
8. When you have finished previewing your book, click the **Book Details** button in the upper-left corner (see Figure 38) to return to the previous page.

![Book Details](image)

**Figure 38: Book Details button**

9. When you have completed all of the fields on the **Your book** page, click the **Save and Continue** button. The **Rights & Pricing** page is displayed.

10. Answer the questions on the **Rights & Pricing** page. At the bottom of the page, read the terms and conditions, click the box to acknowledge, and then click the **Save and Publish** button. If you need to complete any further steps to publish your book, such as providing account information, the KDP website will prompt you. Otherwise, a success message is displayed.